icon-rss-large

中文泛技术类IT博客 | 留言

软路由 | 硬路由 | 网站地图 |

DDNS动态域名脚本(花生壳+3322公云)for ROS 6.x(转)

发表于 2016年08月28日 软路由版

一、花生壳
花生壳动态域名是全球用户量最大的完全免费的动态域名解析软件(DDNS)。当您安装并注册花生壳动态域名解析软件,无论您在任何地点、任何时间、使用任 何线路,均可利用这一服务建立拥有固定域名和最大自主权的互联网主机。“花生壳动态域名解析软件”支持的线路包括普通电话线、ISDN、ADSL、有线电 视网络、双绞线到户的宽带网和其它任何能够提供互联网真实IP的接入服务线路,而无论连接获得的IP属于动态还是静态。
现在花生壳动态域名解析软件为千万的域名提供动态域名解析服务,并广泛应用于网站建设、视频监控、遥感测绘、FTP、VPN、企业OA、ERP等应用领域。

脚本:

local ipaddr
local server “http://ddns.oray.com
local domain “域名”
local par “/ph/update?&hostname=$domain&myip=$ipaddr”
local users “用户”
local paswd “密码”
:set ipaddr [/ip address get [/ip address find interface=pppoe-out2] address]
:set ipaddr [:pick $ipaddr 0 ([len $ipaddr] -3)]
/tool fetch url=($server . $par) mode=http user=$users password=$paswd



二、3322

脚本:


:local ednsuser “用户”
:local ednspass “密码”
:local ednshost “域名”
:local ednsinterface “接口”
:local members “http://members.3322.org/dyndns/update?system=dyndns
#:local members “http://members./nic/update?”
:local status
:local status [/interface get [/interface find name=$ednsinterface] running]
:if ($status!=false) do={
:local ednslastip [:resolve $ednshost]
:if ([ :typeof $ednslastip ] = nil ) do={ :local ednslastip “0” }
:local ednsiph [ /ip address get [/ip address find interface=$ednsinterface ] address ]
:local ednsip [:pick $ednsiph 0 [:find $ednsiph “/”]]
:local ednsstr “&hostname=$ednshost&myip=$ednsip”
:if ($ednslastip != $ednsip) do={/tool fetch url=($members . $ednsstr) mode=http user=$ednsuser password=$ednspass dst-path=$ednshost
:delay 2
:local result [/file get $ednshost contents]
:log info ($ednshost . ” ” .$result)
/file remove $ednshost ;
}
}


本文标题:DDNS动态域名脚本(花生壳+3322公云)for ROS 6.x(转)
本文链接:http://www.yuyouhe.com/index.php/post/920.html
作者授权:除特别说明外,本文由 citywo 原创编译并授权 大城小我 刊载发布。
版权声明:本文不使用任何协议授权,您可以任何形式自由转载或使用。
0
留言区
留言区

pk平台 www.881542.com-辉煌彩票能玩吗| www.um27.com-彩宝彩票官网安卓| www.706030.com-官网国乐彩-| www.116320.com-上海快三走势一定牛| www.246686.com-福彩农场-| www.36687.cc-48彩票官网-| www.9020.com-南宁福彩中心地址| www.88582.com-彩聊app-| www.59672.com-湖北精彩十分5d| www.917256.com-88彩票赌博-| www.hv02.com-中彩网安徽快3| www.386.cn-优乐网上打彩票| www.gh62.com-分分快三好彩下载| www.00uz.com-彩票少一个角| www.1218.xyz-快三一倍多少钱一注| www.90307.com-成功彩票下载软件| www.851182.com-时时彩qq报号群| www.cw90.com-彩神可信吗-| www.74bz.com-买2元黑彩-| www.53179.cc-98时时彩网站| www.123273.com-彩票毁了多少人| www.001616.com-澳门天麟国际购彩| www.117759.com-竞彩管房网比分直播| www.019840.com-彩之星网址-| www.82867.cc-中国福利彩票真实吗| www.047813.com-江苏体育彩票| www.217275.com-快三怎么才能赢钱| www.5036.cc-旺彩全国开奖公告| www.967503.com-体育彩票双色球开奖| www.5jn.com-福彩3d专家杀码村| www.5349.top-网上买彩票怎么领奖| www.426466.com-浙江体彩6十丨| www.917427.com-必赢彩票站app| 福彩网www.055y.cc| www.770290.com-快乐彩票注册| www.769251.com-湖北福彩自助快三| www.872577.com-福彩端是什么软件| www.971874.com-彩22靠谱吗-| www.bh20.com-易彩彩票骗局| www.9gw.cc-体彩中5个数多少钱| www.007607.com-体彩7星-| www.486453.com-足彩什么是拉力| www.213017.com-2345彩票合法吗| www.lz3.cc-兰州市体彩兑奖中心| www.10ir.com-55彩票怎么看走势| www.816447.com-福彩pk10投注| www.399983.com-美国纽约州彩票网站| www.209525.com-河北福彩排列5开奖| www.295131.com-彩吧图谜总汇| www.559268.com-福彩大家乐二维码| www.653538.com-最新体育彩票大奖| www.777241.com-立彩助手邀请码| www.904236.com-星光彩票app完整| www.bj48.com-1分钟一期的快三| www.149448.com-体彩福彩开奖日期| www.280578.com-彩票福彩3d走势图| www.614323.com-民国三彩瓷器| www.687717.com-3d彩票-| www.759129.com-菲律宾大中华彩票| www.831251.com-彩票游戏平台手机版| www.893596.com-双色球彩票软件平台| www.955385.com-凤凰彩票挂机软件| 彩之堂www.77czt.com| www.2998.net-网彩平台出租价格| www.497875.com-百合网交友博彩被骗| www.267860.com-大发时时彩计划软件| www.366376.com-水溶彩铅哪个牌子好| www.501861.com-彩票邀请码qq群| www.381920.com-湖北福彩短信投注站| www.658612.com-彩乐国际网址| www.217579.com-福彩自助彩票机代理| www.470289.com-买足彩属于赌博吗| www.742637.com-重庆中国体育彩票| www.892563.com-彩票榜下截-| www.md06.com-分分快三开奖在哪开| www.ed05.com-百姓彩票网官网下载| www.816.bid-直播买彩票-| www.3058.cc-彩票指南报纸41| www.548257.com-彩票共赢-| www.667892.com-彩票官员落网| www.689928.com-腾讯五分彩在线计划| www.447316.com-初始者买足彩技巧| www.666914.com-七星彩六等奖中奖率| www.774780.com-黄金8彩票网可靠吗| www.699183.com-华夏彩票怎么赢| www.846236.com-彩票是不是太假了| www.995681.com-足彩猜比分规律| www.lo75.com-8方彩票-| www.0483.org-黄金分割法彩票| www.25896.cc-彩虹周杰伦翻唱| www.893279.com-彩票大师软件| www.966703.com-快3彩票大小单双句| www.l76.net-足彩买料-| www.135031.com-彩金网-| www.491081.com-10分彩网站-| www.585654.com-彩票双色球购买时间| www.347998.com-溢彩年华书柜| www.439821.com-转让海口体育彩票| www.522756.com-时时彩追豹子计划| www.602439.com-彩票买不了了吗| www.670233.com-保利彩票是真的吗| www.749156.com-兴罗彩砖厂-| www.42ni.com-看看彩票的开奖情况| www.966653.com-福彩排五开奖走势图| www.313224.com-外围彩票网站哪个好| www.384998.com-重庆时时彩实时结果| www.949202.com-3d彩票图谜总汇| www.998949.com-湖北快三和值走| www.cx00.com-彩名堂ios版| www.sc07.com-快三机选号码查询| www.61061.com-彩吧vip合法吗| www.3646.vip-福彩七乐彩如何兑奖| www.020941.com-众彩网安全吗| www.115019.com-app星光彩票| www.80rs.com-北控国彩合法吗| www.6118.in-加州彩票app| www.81829.cc-七乐彩每周几开奖| www.0935.wang-顺发彩票app| www.315986.com-商业区彩票店| www.412367.com-彩票走势图格式| www.505634.com-炫彩hd动态壁纸| www.dt4.com-王牌彩票骗局| www.uo40.com-爱彩乐十一选五多少| www.616166.com-609彩票网-| www.621831.com-必赢七星彩杀号| www.oi93.com-中国体育彩票走势| www.32lf.com-3d字谜彩吧论坛| www.072935.com-新版天天爱彩票| www.303703.com-甘肃快三助下载安装| www.669825.com-百博七星彩投注网| www.824277.com-七星彩卖奖软件| www.949821.com-九州彩票平台软件| www.wz6.com-福彩3d论坛专区| www.33kg.com-快三中三不同多少钱| www.602701.com-7w彩票-| www.832016.com-足球彩票的软件| www.941666.com-各种彩票代理| www.cp7633.com-七星彩玩法-| www.5078.top-福彩25选7奖结果| www.820342.com-福彩票网-| www.947101.com-彩种计划大全| www.38345.cc-彩票每日抢红包| www.719683.com-彩票对刷漏洞| www.4395.cn-01彩票自带app| www.219853.com-百盈快三高手计划| www.528053.com-重庆时时彩透视软件| www.681265.com-福利彩票3d第彩吧| www.767050.com-竞彩比分直播和赔率| www.69257.cc-500彩票幸运三| www.64356.com-彩妆加盟店哪家好| www.455116.com-金冠彩票软件| www.545028.com-cc彩球网下载| www.608312.com-模拟七星彩彩票| www.55399.com-英国彩票-| www.303014.com-福彩三d走势图表图| www.3767.xyz-篮球竞彩比分直墦| www.349249.com-体彩排列五三等奖| www.513973.com-福彩体彩-| www.657294.com-福利彩票开的游戏厅| www.756198.com-安装旺彩双色球软件| www.972981.com-彩库宝典2015| www.n26.net-京彩江苏快三app| www.539764.com-福州体彩转让信息| www.979320.com-苏式彩画-|